You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
freifunkist-firmware/openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff

13 lines
602 B

diff -ruN olsrd-0.4.9-orig/Makefile olsrd-0.4.9-1/Makefile
--- olsrd-0.4.9-orig/Makefile 2005-03-31 20:39:24.000000000 +0200
+++ olsrd-0.4.9-1/Makefile 2005-04-05 02:14:48.000000000 +0200
@@ -72,7 +72,8 @@
SRCS += $(wildcard src/linux/*.c) $(wildcard src/unix/*.c)
HDRS += $(wildcard src/linux/*.h) $(wildcard src/unix/*.h)
DEFINES = -Dlinux
-CFLAGS ?= $(CCWARNINGS) -O2 -g #-DDEBUG #-pg #-march=i686
+OFLAGS ?= -O2 -g
+CFLAGS ?= $(CCWARNINGS) $(OFLAGS) #-DDEBUG #-pg #-march=i686
LIBS = -lm -ldl #-pg
MAKEDEPEND = makedepend -f $(DEPFILE) $(DEFINES) -Y $(INCLUDES) $(SRCS) >/dev/null 2>&1