Browse Source

Use ruby-2.7.4 (#16481)

Stop using older version of resolv gem as the bug has been fixed.
https://bugs.ruby-lang.org/issues/17781
master
Daigo 3 Dango 2 weeks ago
committed by GitHub
parent
commit
3d5183e99c
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
  1. 2
      .ruby-version
  2. 2
      Dockerfile
  3. 2
      Gemfile
  4. 2
      Gemfile.lock

2
.ruby-version

@ -1 +1 @@
2.7.2
2.7.4

2
Dockerfile

@ -26,7 +26,7 @@ RUN ARCH= && \
mv node-v$NODE_VER-linux-$ARCH /opt/node
# Install Ruby
ENV RUBY_VER="2.7.2"
ENV RUBY_VER="2.7.4"
RUN apt-get update && \
apt-get install -y --no-install-recommends build-essential \
bison libyaml-dev libgdbm-dev libreadline-dev libjemalloc-dev \

2
Gemfile

@ -155,5 +155,3 @@ gem 'concurrent-ruby', require: false
gem 'connection_pool', require: false
gem 'xorcist', '~> 1.1'
gem 'resolv', '~> 0.1.0'

2
Gemfile.lock

@ -491,7 +491,6 @@ GEM
regexp_parser (2.1.1)
request_store (1.5.0)
rack (>= 1.4)
resolv (0.1.0)
responders (3.0.1)
actionpack (>= 5.0)
railties (>= 5.0)
@ -764,7 +763,6 @@ DEPENDENCIES
rdf-normalize (~> 0.4)
redis (~> 4.3)
redis-namespace (~> 1.8)
resolv (~> 0.1.0)
rqrcode (~> 2.0)
rspec-rails (~> 5.0)
rspec-sidekiq (~> 3.1)

Loading…
Cancel
Save